text.skipToContent text.skipToNavigation

Dual-band router issues on Wemo devices

If you are using a dual-band router and having difficulty locating your Wemo® devices through the Wemo app, make sure that your mobile device is connected to the 2.4 GHz WiFi.  Wemo devices may not show in the Wemo app or you might only see the welcome screen if your mobile device is connected to the 5 GHz WiFi.
 
If your Wemo devices are not being detected on a network that uses a dual-band router, try any of the following:


Connecting your mobile device to the 2.4 GHz WiFi
Reconnecting and powercycling your Wemo device
Reinstalling the Wemo app and manually resetting the Wemo
 

Connecting your mobile device to the 2.4 GHz WiFi
 
Step 1:  Close the Wemo app on your mobile device to make sure that it is not running in the background.

Step 2:  On your mobile device, go to Settings.
 

Step 3:  Tap Wi-Fi.

NOTE:  Options may vary depending on the operating system of your mobile device.

Step 4:  Connect to the 2.4 GHz WiFi of your router.

NOTE:  If you want to make sure that you are connected to the correct band of your network, check your router’s settings.  If you are using a Belkin router, click
here to learn more.

Step 5:  Launch the Wemo app again then wait for it to locate your Wemo devices.

If your Wemo devices are still not visible on the Wemo app after performing the steps above, check to make sure they are connected to your WiFi.  If the status light on your Wemo device is solid or blinking orange, the devices are having difficulty staying connected to your network.

If your Wemo devices are connected to your network but they are still not visible in the Wemo app, try reinstalling the Wemo app on your mobile device.

 


Reconnecting and powercycling your Wemo device
 
First, check the lights of your Wemo device.  If it is blinking orange, it means that it has no connectivity to your WiFi.  Try rebooting the Wemo device by unplugging it for 10 seconds and then plugging it back in to the power source.
 


Reinstalling the Wemo app and manually resetting the Wemo
 
Step 1:  Unplug all your Wemo devices.

NOTE:  If you are using a Wemo Smart Light Switch, F7C030, you don't need to unplug it.  Instead, it is recommended that you reset the device to factory default settings.  For step-by-step instructions on how to do this, click
here.
 

Step 2:  Uninstall the Wemo app from your mobile device. 
 

Step 3:  On your Wemo device, press the Reset button and plug it back in.  Do this on all your Wemo units.

Step 4:  Download and reinstall the Wemo app on your mobile device from the App Store® or Google Play™.
 

Step 5:  Set up your Wemo device again.  For a list of Wemo devices and their setup instructions, click here.

Step 6:  After you set up the first Wemo, close the Wemo app and make sure that your mobile device is connected to the 2.4 GHz WiFi.
 

Step 7:  Open the Wemo app again.  Make sure that you can control your Wemo device with the Wemo app before you proceed with setting up the rest of your Wemo devices.

QUICK TIP:  When setting up multiple Wemo devices, leave each Wemo plugged in while you set up the next.  Wemo devices communicate with each other and leaving them plugged in helps ensure a proper setup.

Was this support article useful?

Thank you for your feedback.

Additional Support Questions?

Search Again

CONTACT SUPPORT

  • RMA WEB FORM

    Some of our products can be replaced by completing our online RMA form.
    PLEASE CLICK HERE If your product is not listed, please choose another support option.
  • LIVE CHAT

    A customer advocate will answer your questions. START LIVE CHAT
  • PHONE

    Have questions about your Belkin product? Contact our support team. CALL US
  • TWITTER

    Post your issue to Twitter, and we will reply in minutes. Tweet @BelkinCares

Loading Shopping Cart...