text.skipToContent text.skipToNavigation

Error when installing the USB Control Center on Mac OS X® 10.11

The Belkin USB Control Center software (USB Printer Utility) v2.X.X and below are NOT compatible with a Mac® computer running on OS X® El Capitan 10.11.  You will receive the "SXUPTP Driver has not been installed. Please install the application again.” error message.  

We are currently working on a solution to fix this concern. If you receive the following message, please uninstall the USB Control Center software.

 
User-added image

Below is a list of supported Mac Operating Systems for your USB printer:

OS X Leopard 10.5.8 or later
OS X Snow Leopard 10.6.1 or later
OS X Lion 10.7
OS X Mountain Lion 10.8
OS X Mavericks 10.9
OS X Yosemite 10.10 (using software v2.1.0 and v2.1.1)

Was this support article useful?

Thank you for your feedback.

Additional Support Questions?

Search Again

CONTACT SUPPORT

  • PHONE

    Have questions about your Belkin product? Contact our support team. CALL US
  • LIVE CHAT

    A customer advocate will answer your questions. START LIVE CHAT
  • TWITTER

    Post your issue to Twitter, and we will reply in minutes. Tweet @BelkinCares
  • CONNECTED EQUIPMENT WARRANTY

    Find out what to do if your product is not working as expected. Learn More