text.skipToContent text.skipToNavigation

N600 Dual-Band Plug-In Wi-Fi® Range Extender, F9K1122 minimum system requirements

The Belkin N600, F9K1122 is a dual-band range extender that expands your wireless network.

Before setting up your range extender, check the list below to verify if your computer's operating system is compatible with the device.

  • 802.11a/b/g/n 2.4 GHz and/or 5 GHz wireless router with broadband Internet connection
  • At least one (1) computer with:

- Installed wireless network interface card and TCP/IP protocol

- Windows® XP 32-bit (SP3 or greater), Windows Vista® 32-bit/64-bit, or Windows 7 32-bit/64-bit; or Mac OS® X v10.5 or above

- Internet Explorer® v7 or above, Firefox®, Google Chrome™, or Safari®

- Minimum of 1.8 GHz processor

Was this support article useful?

Thank you for your feedback.

Additional Support Questions?

Search Again